Main website and Client area issues
Incident Report for FreshSites Limited
Resolved
This issue has now been resolved - The website and client areas are now accessible.
Posted 9 months ago. Oct 04, 2018 - 11:20 BST
Investigating
Our main website, as well as client account areas are currently down and inaccessible. We are currently investigating the cause of this issue.
Posted 9 months ago. Oct 04, 2018 - 10:59 BST
This incident affected: Front-End Services (freshsites.co.uk).